Cum se instalează Metasploit Framework pe Ubuntu 18.04 / Debian 9

Ne puteți sprijini descărcând acest articol în format PDF din Link-ul de mai jos. Descărcați ghidul în format PDF

În acest articol, vom discuta despre cum se instalează Metasploit Framework pe Ubuntu 18.04 / Debian 9. Metasploit Framework este un proiect open source care oferă infrastructura, conținutul și instrumentele necesare pentru a efectua audituri de securitate și teste de penetrare extinse.

Edițiile comerciale ale Metasploit sunt disponibile pentru utilizatorii care preferă să folosească o interfață web pentru pentest. Cadrul Metasploit rulează următoarele servicii.

  • Serverul de baze de date PostgreSQL – utilizat de Metasploit pentru a stoca datele dintr-un proiect.
  • Ruby on Rails
  • Serviciul Metasploit

Requisite pentru Cadrul Metasploit

Mai jos sunt cerințele hardware minime pentru rularea Cadrului Metasploit pe Ubuntu 18.04 / Debian 9.

  • Procesor de peste 2 GHz
  • 4 GB de memorie RAM disponibilă (8 GB recomandat)
  • 1 GB spațiu disponibil pe disc (50 GB recomandat)
  • Versiunea pe 64 de biți a Ubuntu 18.04 / Debian 9

Instalați Metasploit Framework pe Ubuntu 18.04 / Debian 9

Cel mai simplu mod de a instala Metasploit Framework pe Ubuntu 18.04 / Debian 9 este din programul de instalare Metasploit. Acest program de instalare este livrat cu toate dependențele și instrumentele necesare pentru a rula Metasploit Framework.

Descărcați programul de instalare Metasploit executând comenzile de mai jos în terminalul dumneavoastră.

După ce scriptul este descărcat, faceți-l executabil

chmod 755 msfinstall

Apoi executați:

Crearea și inițializarea bazei de date msf.

$ msfdb init
Creating database at /home/jmutai/.msf4/db
Starting database at /home/jmutai/.msf4/db…success
Creating database users
Creating initial database schema

Launch msfconsole

Baza de date este inițializată, puteți lansa

$ msfconsole

Sample output

Verificați conectivitatea bazei de date cu comanda db_status, așa cum se arată mai jos.

msf > db_status
postgresql connected to msf
msf >

Actualizarea Framework-ului Metasploit

Pentru a actualiza Framework-ul Metasploit pe Ubuntu 18.04 / Debian 9. rulați comanda:

# msfupdate
Updating package cache..OK
Checking for and installing update..
Reading package lists… Done
Building dependency tree
Reading state information… Done
metasploit-framework is already the newest version (4.17.35+20190105104028~1rapid7-1).
0 upgraded, 0 newly installed, 0 to remove and 123 not upgraded.

Puteți verifica versiunea Framework-ului dvs. folosind:

# msfconsole --version
Framework Version: 4.17.35-dev-

Salutare! Acum aveți instalat Metasploit Framework pe sistemul Ubuntu 18.04 / Debian 9.

Ne puteți sprijini descărcând acest articol în format PDF de la Linkul de mai jos. Descărcați ghidul în format PDF

.

Lasă un răspuns

Adresa ta de email nu va fi publicată.