Como instalar o Metasploit Framework no Ubuntu 18.04 / Debian 9

Você pode nos suportar baixando este artigo como PDF do link abaixo. Baixe o guia em PDF

Neste artigo, discutiremos como instalar o Metasploit Framework no Ubuntu 18.04 / Debian 9. Metasploit Framework é um projeto de código aberto que fornece a infra-estrutura, conteúdo e ferramentas para realizar auditorias de segurança extensivas e testes de penetração.

As edições comerciais do Metasploit estão disponíveis para usuários que preferem usar uma interface web ao pentest. O Metasploit Framework roda os seguintes serviços.

  • Servidor de banco de dados PostgreSQL – usado pelo Metasploit para armazenar dados de um projeto.
  • Ruby on Rails
  • Metasploit service

Metasploit Framework Requirements

Below são os requisitos mínimos de hardware para rodar o Metasploit Framework no Ubuntu 18.04 / Debian 9.

  • 2 GHz+ processador
  • 4 GB de RAM disponível (8 GB recomendado)
  • 1 GB de espaço disponível em disco (50 GB recomendado)
  • 64-bit versão do Ubuntu 18.04 / Debian 9

Instalar Metasploit Framework no Ubuntu 18.04 / Debian 9

A forma mais fácil de instalar o Metasploit Framework no Ubuntu 18.04 / Debian 9 é a partir do instalador do Metasploit. Este instalador vem com todas as dependências e ferramentas necessárias para executar o Metasploit Framework.

Download do instalador Metasploit executando os comandos abaixo no seu terminal.

Após o download do script,torne-o executável

chmod 755 msfinstall

Então execute:

Criar e inicializar o banco de dados msf.

$ msfdb init
Creating database at /home/jmutai/.msf4/db
Starting database at /home/jmutai/.msf4/db…success
Creating database users
Creating initial database schema

Launch msfconsole

base de dados é inicializada, você pode iniciar

$ msfconsole

Sample output

Verify database connectivity with the db_status command as shown below.

msf > db_status
postgresql connected to msf
msf >

Atualizar o Metasploit Framework

Para atualizar seu Metasploit Framework no Ubuntu 18.04 / Debian 9. execute o comando:

# msfupdate
Updating package cache..OK
Checking for and installing update..
Reading package lists… Done
Building dependency tree
Reading state information… Done
metasploit-framework is already the newest version (4.17.35+20190105104028~1rapid7-1).
0 upgraded, 0 newly installed, 0 to remove and 123 not upgraded.

Você pode verificar sua versão do Framework usando:

# msfconsole --version
Framework Version: 4.17.35-dev-

Cheers! Você agora tem o Metasploit Framework instalado no Ubuntu 18.04 / Debian 9 system.

Você pode nos suportar baixando este artigo como PDF do link abaixo. Baixe o guia em formato PDF

Deixe uma resposta

O seu endereço de email não será publicado.