Comment installer le framework Metasploit sur Ubuntu 18.04 / Debian 9

Vous pouvez nous soutenir en téléchargeant cet article en PDF à partir du Lien ci-dessous. Télécharger le guide en PDF

Dans cet article, nous allons discuter de la façon d’installer Metasploit Framework sur Ubuntu 18.04 / Debian 9. Metasploit Framework est un projet open source qui fournit l’infrastructure, le contenu et les outils pour effectuer des audits de sécurité et des tests de pénétration étendus.

Les éditions commerciales de Metasploit sont disponibles pour les utilisateurs qui préfèrent utiliser une interface web pour pentester. Le cadre Metasploit exécute les services suivants.

  • Serveur de base de données PostgreSQL – utilisé par Metasploit pour stocker les données d’un projet.
  • Ruby on Rails
  • Service Metasploit

Configuration du cadre Metasploit

Vous trouverez ci-dessous la configuration matérielle minimale requise pour exécuter Metasploit Framework sur Ubuntu 18.04 / Debian 9.

  • Processeur de 2 GHz+
  • 4 Go de RAM disponibles (8 Go recommandés)
  • 1 Go d’espace disque disponible (50 Go recommandés)
  • Version 64 bits d’Ubuntu 18.04 / Debian 9

Installer Metasploit Framework sur Ubuntu 18.04 / Debian 9

La façon la plus simple d’installer Metasploit Framework sur Ubuntu 18.04 / Debian 9 est à partir de l’installateur Metasploit. Cet installateur est livré avec toutes les dépendances et les outils nécessaires pour exécuter le Metasploit Framework.

Téléchargez l’installateur Metasploit en exécutant les commandes ci-dessous dans votre terminal.

Une fois le script téléchargé, rendez-le exécutable

chmod 755 msfinstall

Puis exécutez :

Créer et initialiser la base de données msf.

$ msfdb init
Creating database at /home/jmutai/.msf4/db
Starting database at /home/jmutai/.msf4/db…success
Creating database users
Creating initial database schema

Lancer msfconsole

La base de données est initialisée, vous pouvez lancer

$ msfconsole

Sortie échantillon

Vérifier la connectivité de la base de données avec la commande db_status comme indiqué ci-dessous.

msf > db_status
postgresql connected to msf
msf >

Mise à jour du Framework Metasploit

Pour mettre à jour votre Framework Metasploit sur Ubuntu 18.04 / Debian 9. exécutez la commande :

# msfupdate
Updating package cache..OK
Checking for and installing update..
Reading package lists… Done
Building dependency tree
Reading state information… Done
metasploit-framework is already the newest version (4.17.35+20190105104028~1rapid7-1).
0 upgraded, 0 newly installed, 0 to remove and 123 not upgraded.

Vous pouvez vérifier la version de votre Framework en utilisant :

# msfconsole --version
Framework Version: 4.17.35-dev-

Cheers ! Vous avez maintenant installé Metasploit Framework sur le système Ubuntu 18.04 / Debian 9.

Vous pouvez nous soutenir en téléchargeant cet article en PDF à partir du Lien ci-dessous. Télécharger le guide en PDF

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.