Sådan installeres Metasploit Framework på Ubuntu 18.04 / Debian 9

Du kan støtte os ved at downloade denne artikel som PDF fra nedenstående link. Download vejledningen som PDF

I denne artikel vil vi diskutere, hvordan man installerer Metasploit Framework på Ubuntu 18.04 / Debian 9. Metasploit Framework er et open source-projekt, der leverer infrastruktur, indhold og værktøjer til at udføre omfattende sikkerhedsauditering og penetrationstest.

De kommercielle udgaver af Metasploit er tilgængelige for brugere, som foretrækker at bruge en webgrænseflade til pentest. Metasploit Framework kører følgende tjenester:

  • PostgreSQL-databaseserver – bruges af Metasploit til at gemme data fra et projekt.
  • Ruby on Rails
  • Metasploit-tjeneste

Metasploit Framework-krav

Nedenfor er de minimale hardwarekrav for at køre Metasploit Framework på Ubuntu 18.04 / Debian 9.

  • 2 GHz+ processor
  • 4 GB RAM tilgængelig (8 GB anbefales)
  • 1 GB ledig diskplads (50 GB anbefales)
  • 64-bit version af Ubuntu 18.04 / Debian 9

Installer Metasploit Framework på Ubuntu 18.04 / Debian 9

Den nemmeste måde at installere Metasploit Framework på Ubuntu 18.04 / Debian 9 på er fra Metasploit-installationsprogrammet. Dette installationsprogram leveres med alle de afhængigheder og værktøjer, der kræves for at køre Metasploit Framework.

Download Metasploit installer ved at køre nedenstående kommandoer i din terminal.

Når scriptet er downloadet, skal du gøre det eksekverbart

chmod 755 msfinstall

Dernæst skal du udføre:

Opret og initialisér msf-databasen.

$ msfdb init
Creating database at /home/jmutai/.msf4/db
Starting database at /home/jmutai/.msf4/db…success
Creating database users
Creating initial database schema

Lancer msfconsole

Databasen er initialiseret, kan du starte

$ msfconsole

Sample output

Verificer databaseforbindelsen med db_status-kommandoen som vist nedenfor.

msf > db_status
postgresql connected to msf
msf >

Opdatering af Metasploit Framework

For at opdatere dit Metasploit Framework på Ubuntu 18.04 / Debian 9. kør kommandoen:

# msfupdate
Updating package cache..OK
Checking for and installing update..
Reading package lists… Done
Building dependency tree
Reading state information… Done
metasploit-framework is already the newest version (4.17.35+20190105104028~1rapid7-1).
0 upgraded, 0 newly installed, 0 to remove and 123 not upgraded.

Du kan kontrollere din Framework-version ved hjælp af:

# msfconsole --version
Framework Version: 4.17.35-dev-

Hilsen!. Du har nu Metasploit Framework installeret på Ubuntu 18.04 / Debian 9-systemet.

Du kan støtte os ved at downloade denne artikel som PDF fra nedenstående link. Download vejledningen som PDF

Skriv et svar

Din e-mailadresse vil ikke blive publiceret.