Cómo instalar Metasploit Framework en Ubuntu 18.04 / Debian 9

Puedes apoyarnos descargando este artículo en PDF desde el siguiente enlace. Descargar la guía como PDF

En este artículo, vamos a discutir cómo instalar Metasploit Framework en Ubuntu 18.04 / Debian 9. Metasploit Framework es un proyecto de código abierto que proporciona la infraestructura, el contenido y las herramientas para realizar una amplia auditoría de seguridad y pruebas de penetración.

Las ediciones comerciales de Metasploit están disponibles para los usuarios que prefieren utilizar una interfaz web para hacer pentest. El Metasploit Framework ejecuta los siguientes servicios.

  • Servidor de base de datos PostgreSQL – utilizado por Metasploit para almacenar los datos de un proyecto.
  • Ruby on Rails
  • Servicio de Metasploit

Requerimientos de Metasploit Framework

A continuación se muestran los requisitos mínimos de hardware para ejecutar Metasploit Framework en Ubuntu 18.04 / Debian 9.

  • Procesador de 2 GHz+
  • 4 GB de RAM disponible (8 GB recomendados)
  • 1 GB de espacio disponible en disco (50 GB recomendados)
  • Versión de 64 bits de Ubuntu 18.04 / Debian 9

Instalar Metasploit Framework en Ubuntu 18.04 / Debian 9

La forma más sencilla de instalar Metasploit Framework en Ubuntu 18.04 / Debian 9 es desde el instalador de Metasploit. Este instalador viene con todas las dependencias y herramientas necesarias para ejecutar el Metasploit Framework.

Descarga el instalador de Metasploit ejecutando los siguientes comandos en tu terminal.

Una vez descargado el script, hazlo ejecutable

chmod 755 msfinstall

Entonces ejecuta:

Crea e inicializa la base de datos msf.

$ msfdb init
Creating database at /home/jmutai/.msf4/db
Starting database at /home/jmutai/.msf4/db…success
Creating database users
Creating initial database schema

Lanzamiento de msfconsole

La base de datos está inicializada, puede lanzar

$ msfconsole

Muestra de salida

Verifique la conectividad de la base de datos con el comando db_status como se muestra a continuación.

msf > db_status
postgresql connected to msf
msf >

Actualización de Metasploit Framework

Para actualizar tu Metasploit Framework en Ubuntu 18.04 / Debian 9. ejecuta el comando:

# msfupdate
Updating package cache..OK
Checking for and installing update..
Reading package lists… Done
Building dependency tree
Reading state information… Done
metasploit-framework is already the newest version (4.17.35+20190105104028~1rapid7-1).
0 upgraded, 0 newly installed, 0 to remove and 123 not upgraded.

Puedes comprobar la versión de tu Framework utilizando:

# msfconsole --version
Framework Version: 4.17.35-dev-

¡Cheers!. Ya tienes Metasploit Framework instalado en el sistema Ubuntu 18.04 / Debian 9.

Puedes apoyarnos descargando este artículo en PDF desde el siguiente Enlace. Descargar la guía como PDF

Deja una respuesta

Tu dirección de correo electrónico no será publicada.